GAA 3560G Configuration 20170209
copy scp://[username]@[ip address]//path/to/bin/file flash:
Alternatively copy tftp flash:
[tftp server]
c3560-ipbasek9-mz.150-2.SE10a.bin
Alternatively copy ftp://username:password@ipaddress/c3560-ipbasek9-mz.150-2.SE10a.bin flash:
conf t
boot system flash:c3560-ipbasek9-mz.150-2.SE10a.bin
delete flash:vlan.dat
write erase
reload
configure vlan1 ip address
configure terminal
int vlan1
ip address [ip address] [netmask]
ip default-gateway [default gateway]
ip broadcast-address [broadcast address]
no shut
exit
configure enable password
enable secret [password]
service password-encryption
configure for ssh
hostname [hostname]
ip domain-name [domain name]
crypto key generate rsa - use 2048-bit key
ip name-server [dns server]
configure for user
aaa new-model
aaa authentication login default local
username [username] privilege 1 password 0 [password]
set up trunks
int [interface]
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 60
exit
configure vtp
vtp domain [domain name]
vtp version 2
vtp mode server
vtp password [password]
set up snmp
snmp-server community [snmp string]
add ftp user
ip ftp username [ftp user]
ip ftp password [ftp user password]
enable lldp
lldp run
save config
wr mem
Optional: PortFast
conf t
int [ports]
spanning-tree portfast
end
copy run start
Optional: Disable PortFast
spanning-tree portfast disable
Optional: save config to ftp server
copy running-config ftp: